$re = '/\\\\#|#(.*?)#/';
$str = 'This is a #date# test.
This is a \\#date# test.
This is another #test# and i don\'t want \\#this#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);