using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^P((%d)+)D).*";
string input = @"P0DT0H22M56S";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}