use strict;
my $str = 'content example <abbr variable-title="notepad 1">data <abbr variable-title="notepad 2">sample value </abbr>sample conten</abbr> <abbr variable-title="notepad 2">sample value </abbr>';
my $regex = qr/<abbr>(\S.*?)<\/abbr>/ip;
my $subst = '<span class=\'notranslate\'>$1</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";