$re = '/(?i)msie [1-8]\.[0]/i';
$str = 'Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);