re = /\[([0-9]+)\.\s([^\]]+)\]/i
str = 'Lorem ipsum [1. dolor sit amet, [consectetuer adipiscing] elit.]. Aenean commodo ligula eget dolor.[2. Dolor, [consectetuer adipiscing] elit.] Aenean massa[3. Lorem ipsum] dolor.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end