re = /\$?\b(?![0-9])\w+\b/m
str = '= (cotimeataddressyears * 12) + cotimeataddressmonths2 * $somevar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end