$re = '/(?<!\s)-(?!\s)/';
$str = 'dash-to-space';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;