using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^~";
string substitution = @"sdfsdf.pdf";
string input = @"dgdfgdfg~sdfsdf.pdf";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}