$re = '/^~/m';
$str = 'dgdfgdfg~sdfsdf.pdf';
$subst = "sdfsdf.pdf";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;