package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^~`)
var str = `dgdfgdfg~sdfsdf.pdf`
var substitution = "sdfsdf.pdf"
fmt.Println(re.ReplaceAllString(str, substitution))
}