import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+)@(.+)(\\.[a-zA-Z1-9]{2,6})";
final String string = "\n"
+ "goose@down.com\n"
+ "blah@192.168.1.255\n"
+ "blah@255.255.255.255\n"
+ "blah@0.0.0.0\n"
+ "gah@1.1.1.01\n"
+ "blah@127.0.0.1\n"
+ "blah@192.168.1.1\n"
+ "blah@domain.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}