re = /\w+(?![^\[]*\])/
str = 'andres [andres andres] andres [andres] andresX andres'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end