const regex = /<a(.*)href="([^"]*)"(.*)>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a(.*)href="([^"]*)"(.*)>', 'g')
const str = `<p><b>Piano:</b><br /></p><p><a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3374"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2302.jpg" alt="Griglie in ghisa" title="Griglie in ghisa" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3368"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2300.jpg" alt="Bruciatore Ultrarapido" title="Bruciatore Ultrarapido" /></a> <br /></p><p class="dot">7 bruciatori a gas, di cui 1 Ultrarapido (4,2 kW)<br /></p><p><br /></p><p><b>Forno principale, superiore:</b><br /></p><p><a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3372"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/A.jpg" alt="A" title="A" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/4225"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func1548.jpg" alt="4 livelli di cottura" title="4 livelli di cottura" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3369"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2320.jpg" alt="Smalto Ever Clean" title="Smalto Ever Clean" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3665"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func1518.jpg" alt="Volta Mobile" title="Volta Mobile" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3371"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2318.jpg" alt="Interno porta tuttovetro" title="Interno porta tuttovetro" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3671"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2316.jpg" alt="Vetro interno rimovibile" title="Vetro interno rimovibile" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3373"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2314.jpg" alt="Porta a triplo vetro" title="Porta a triplo vetro" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3370"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2324.jpg" alt="Raffreddamento tangenziale" title="Raffreddamento tangenziale" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3675"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2328.jpg" alt="Guide telescopiche" title="Guide telescopiche" /></a> <br /></p><p class="dot">Forno elettrico multifunzione termoventilato, 7 funzioni<br /></p><p>compresa funzione di pulizia Vapor Clean<br /></p><p class="dot">Opzione programmazione di inizio e fine cottura con allarme<br /></p><p>acustico di fine cottura<br /></p><p class="dot">Display / Orologio: elettronico a 5 tasti<br /></p><p><b>Forno secondario, inferiore:</b><br /></p><p><a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3372"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/A.jpg" alt="A" title="A" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/4225"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func1548.jpg" alt="4 livelli di cottura" title="4 livelli di cottura" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3369"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2320.jpg" alt="Smalto Ever Clean" title="Smalto Ever Clean" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3665"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func1518.jpg" alt="Volta Mobile" title="Volta Mobile" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3371"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2318.jpg" alt="Interno porta tuttovetro" title="Interno porta tuttovetro" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3671"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2316.jpg" alt="Vetro interno rimovibile" title="Vetro interno rimovibile" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3373"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2314.jpg" alt="Porta a triplo vetro" title="Porta a triplo vetro" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3370"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2324.jpg" alt="Raffreddamento tangenziale" title="Raffreddamento tangenziale" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3675"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2328.jpg" alt="Guide telescopiche" title="Guide telescopiche" /></a> <br /></p><p class="dot">Forno elettrico multifunzione ventilato, 7 funzioni<br /></p><p>compresa funzione di pulizia Vapor Clean<br /></p><p><b>Forno ausiliario, superiore:</b><br /></p><p><a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/4710"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func1552.jpg" alt="2 livelli di cottura" title="2 livelli di cottura" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3369"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2320.jpg" alt="Smalto Ever Clean" title="Smalto Ever Clean" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3665"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func1518.jpg" alt="Volta Mobile" title="Volta Mobile" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3371"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2318.jpg" alt="Interno porta tuttovetro" title="Interno porta tuttovetro" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3671"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2316.jpg" alt="Vetro interno rimovibile" title="Vetro interno rimovibile" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3373"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2314.jpg" alt="Porta a triplo vetro" title="Porta a triplo vetro" /></a> <a class="dialog function_link" dclass="function_dialog" dwidth="500" dheight="auto" href="http://www.smeg.it/ajax/view_function/3370"><img src="http://www.smeg.it/smeg_it/images/functions/0/0/Func2324.jpg" alt="Raffreddamento tangenziale" title="Raffreddamento tangenziale" /></a> <br /></p><p class="dot">Forno elettrico 1 funzione<br /></p><p><br /></p><p class="dot">Vano portaoggetti con apertura a cassetto<br /></p><p class="dot"><b>Porta dei forni principale e secondario con apertura <br /></p><p>laterale</b><br /></p><p class="dot">DIMENSIONI: LxPxH 110x60x91 cm</p>`;
const subst = `<a$1href="javascript:alert(\'Test\');"$3>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);