$re = '/[A-Za-z\W0-9]+(?=[@])/m';
$str = 'askjdnjasd@webycorp.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);