# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\b[A-z0-9._%+-]+@[A-z0-9.-]+\.[A-z]+\b$"
test_str = ("email@example.com\n"
"firstname.lastname@example.com\n"
"email@subdomain.example.com\n"
"firstname+lastname@example.com\n"
"1234567890@example.com\n"
"email@example-one.com\n"
"_______@example.com\n"
"email@example.name\n"
"email@example.museum\n"
"email@example.co.jp\n"
"firstname-lastname@example.com\n\n"
"plainaddress\n"
"#@%^%#$@#$@#.com\n"
"@example.com\n"
"Joe Smith <email@example.com>\n"
"email.example.com\n"
"email@example@example.com\n"
".email@example.com\n"
"あいうえお@example.com\n"
"email@example.com (Joe Smith)\n"
"email@example\n"
"email@111.222.333.44444\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.