$re = '/\[[^[\]]*\](?=[^\[]*\])/';
$str = '[Interim Review[s]] are g[iv]en [by m[a]in head] and [no one e[lse has] th]e access
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);