$re = '/D.{1,5}?/';
$str = '123456789D12345D678904';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);