re = /[\[](.*?)\s|(?<=^|\s)([^=\s]+)="((?:[^\\"]|\\.)*)/
str = '[sig@Sig ver="1" rsID="1\\"234" ... signature="..."][sigSig ver="1" rsID="1\\"234" ... signature="..."]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end