$re = '/\d{1,2}:\d{1,2}\s[AP][M]/';
$str = '10:15 AM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);