$re = '/‘[^‘’]{230,}(?=’)/m';
$str = 'this is a test ‘quote here quote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote here’
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);