# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?i)(<a)(?=((?:[^>"']|"[^"]*"|'[^']*')*?\shref\s*=\s*(['"])\\/mycms\\/~\\/link\.aspx\?_id=)([a-f0-9]{32})(&_z=z\3(?:"[\S\s]*?"|'[\S\s]*?'|[^>]*?)+>))\s+(?:"[\S\s]*?"|'[\S\s]*?'|[^>]*?)+>/$1$2key{$4}$5/;t' <<< "<a hello world href=\"/mycms/~/link.aspx?_id=D9423CEFED254610A5DC6B096A297E17&_z=z\" class>
...
</a>
<img hello world src=\"/mycms/~/media/B1FB91AC357347BD84913D56B8791D03.ashx\" alt=\"\" width=\"690\" height=\"202\" />
"