const regex = /^([0-9]{1}[ ]?)?((?!opw|lie|gez).)[a-zA-Z]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9]{1}[ ]?)?((?!opw|lie|gez).)[a-zA-Z]+', 'gm')
const str = `Genesis 1: 18-20
exodus 3: 15
micha
1 koningen
Johannes 4
1 Johannes 4
2 Johannes 4:15-20
psalm 150
psalm 144:2
psalmen 117
psalmen 10: 1-15
numeri 4: 1, 15-20
numeri 4: 1-5, 15-19
numeri 4: 1, 6, 15-21
numeri 4: 15 - 5:20
numeri 4:15-5:20
psalm 150
lied 15: 1, 2, 3
opwe 144: 1-5
144: 1-5
117
119:1,6,8-10
3:14
^([0-9]{1}[ ]?)?[a-zA-Z]+
((!opwekking)|(lied)|(!gez))[a-zA-Z]+`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}