$re = '/\^[(][)]$/m';
$str = 'ВХОДНЫЕ ДВЕРИ МОДЕЛЬ ELLIPSA КОМПЛЕКТАЦИЯ COMFORT (442)
Thor (22222)ธอร์';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;