import re
regex = re.compile(r"^(?<prefix>.?)\[(?<code>[ABCDEFabcdef0123456789]{6})\](?<suffix>.*?)(\[-\])", flags=re.MULTILINE)
test_str = ("[E16213]Calories: 1[-]\n"
"Crafting ingredient\n"
"Amanita Mushroom\n"
"Amanita Mushrooms\n"
"[E16213]Calories: 10[-]\n"
"Poisonous\n"
"Arm\n"
"Arms\n"
"[E16213]Calories: 600[-]\n"
"Arrows\n"
"Batteries\n"
"Refills torch\n"
"Blackberries\n"
"[E16213]Calories: 1[-]\n"
"Blue Paint\n"
"Crafting ingredient\n"
"BlueBerries\n"
"[E16213]Calories: 1[-]\n"
"Blueberry Bush Seed\n"
"Blueberry Bush Seeds\n"
"Use in gardens\n"
"Bone\n"
"Bones\n"
"Crafting ingredient\n"
"Bone Armor\n"
"Increases [ffce00]Armor[-]\n"
"Booze\n"
"[E16213]Calories: 200[-] \n"
"Crafting ingredient\n"
"Broken Toy\n"
"Broken Toys\n"
"A piece of Timmy's toy\n"
"Camcorder\n"
"Find tapes to view\n"
"Cash\n"
"Use to stoke fires\n"
"Cassette 1\n"
"Fatal Request - \\\"Stronghold\\\"\n"
"Cassette 2\n"
"The Slaps - \\\"No Conscience\\\"\n"
"Cassette 3\n"
"Frankie Millionaire -\\\"Do It\\\"\n"
"Cassette 4\n"
"Wolf on Fire - \\\"The Haunting\\\"\n"
"Cassette 5\n"
"Rick Gold - \\\"S,A,W\\\"\n"
"Cassette Player\n"
"Cassette Players\n"
"Restores [02a1ff]Energy[-]\n"
"Cave Map\n"
"Cave Maps\n"
"Chainsaw\n"
"Chanterelle Mushroom\n"
"Chanterelle Mushrooms\n"
"[E16213]Calories: 10[-]\n"
"Chicory\n"
"[E16213]Calories: 1[-]\n"
"Crafting ingredient\n"
"Circuit Board\n"
"Circuit Boards\n"
"Crafting ingredient\n"
"Climbing Axe\n"
"Climbing Axes\n"
"Cloth\n"
"Crafting ingredient\n"
"Club\n"
"Clubs\n"
"Coins\n"
"Crafting ingredient\n"
"Compass\n"
"Compasses\n"
"Coneflower\n"
"[E16213]Calories: 1[-]\n"
"Crafting ingredient\n"
"Coneflower Seed\n"
"Coneflower Seed\n"
"Use in gardens\n"
"Crafted Axe\n"
"Crafted Axes\n"
"Crafted Bow\n"
"Crafted Bows\n"
"Crafted Club\n"
"Crafted Clubs\n"
"Deer Mushroom\n"
"Deer Mushrooms\n"
"[E16213]Calories: 10[-]\n"
"Deer Skin\n"
"Crafting ingredient\n"
"Dynamite\n"
"Electrical Tape\n"
"Electrical Tapes\n"
"Crafting ingredient\n"
"Energy Mix\n"
"Increases Stamina\n"
"Energy Mix +\n"
"Greatly increases stamina\n"
"Explosive\n"
"Explosives\n"
"Feather\n"
"Feathers\n"
"Crafting ingredient\n"
"Fire Torch\n"
"Fire Torches\n"
"Fish\n"
"[E16213]Calories: 500[-]\n"
"Use on fire\n"
"Flare \n"
"Flares\n"
"Flare Gun\n"
"Flare Guns\n"
"Flare Gun Ammo\n"
"Refills flare Gun\n"
"Flintlock Pistol\n"
"Flintlock Pistols\n"
"Fuel Can\n"
"Fuel Cans\n"
"Refills chainsaw\n"
"Meat\n"
"[E16213]Calories: 600[-]\n"
"Use on fire\n"
"Gold Keycard\n"
"Use on door\n"
"Head\n"
"Heads\n"
"Use on fire\n"
"Head Bomb\n"
"Head Bombs\n"
"Jack Mushroom\n"
"Jack Mushrooms\n"
"[E16213]Calories: 10[-]\n"
"Katana\n"
"Katanas\n"
"Keycard\n"
"Keycards\n"
"Use on door\n"
"Leaf\n"
"Leaves\n"
"Crafting ingredient\n"
"Leg\n"
"Legs\n"
"[E16213]Calories: 600[-]\n"
"LibertyCap Mushroom\n"
"LibertyCap Mushrooms\n"
"[E16213]Calories: 10[-]\n"
"Lighter\n"
"Lighters\n"
"Lizard\n"
"Lizards\n"
"[E16213]Calories: 600[-]\n"
"Use on fire\n"
"Lizard Skin\n"
"Increases [ffce00]Armor[-]\n"
"Log\n"
"Logs\n"
"Machete\n"
"Map 1/4\n"
"Torn part of map\n"
"Map 2/4\n"
"Torn part of map\n"
"Map 3/4\n"
"Torn part of map\n"
"Map 4/4\n"
"Torn part of map\n"
"Map Cave 2\n"
"Marigold\n"
"[E16213]Calories: 1[-]\n"
"Crafting ingredient\n"
"Meds\n"
"Restores [ff0404]Health[-]\n"
"Health Mix\n"
"Restores [ff0404]Health[-]\n"
"Health Mix +\n"
"Restores [ff0404]Health[-]\n"
"Metal Tin Tray\n"
"Metal Tin Trays\n"
"Share items \n"
"Modern Axe\n"
"Modern Axes\n"
"Modern Bow\n"
"Modern Bow\n"
"Molotov\n"
"Molotovs\n"
"Old Gun Ammo\n"
"Crafting ingredient\n"
"Old Gun Part 1 of 8\n"
"Crafting ingredient\n"
"Old Gun Part 2 of 8\n"
"Crafting ingredient\n"
"Old Gun Part 3 of 8\n"
"Crafting ingredient\n"
"Old Gun Part 4 of 8\n"
"Crafting ingredient\n"
"Old Gun Part 5 of 8\n"
"Crafting ingredient\n"
"Old Gun Part 6 of 8\n"
"Crafting ingredient\n"
"Old Gun Part 7 of 8\n"
"Crafting ingredient\n"
"Old Gun Part 8 of 8\n"
"Crafting ingredient\n"
"Old Photo 1 of 8\n"
"Old Photo 2 of 8\n"
"Old Photo 3 of 8\n"
"Old Photo 4 of 8\n"
"Old Photo 5 of 8\n"
"Old Photo 6 of 8\n"
"Old Photo 7 of 8\n"
"Old Photo 8 of 8\n"
"Old Pot\n"
"Old Pots\n"
"%\n"
"Use to boil water\n"
"Orange Paint\n"
"Crafting ingredient\n"
"Oyster\n"
"Oysters\n"
"[E16213]Calories: 10[-]\n"
"Passenger Manifest\n"
"Passenger Manifests\n"
"Find the missing passengers!\n"
"Pedometer\n"
"Pedometers\n"
"[00fff4]Steps Taken[-] %\n"
"Plane Axe\n"
"Plane Axes\n"
"Plastic Torch\n"
"Plastic Torches\n"
"BATTERY: %\n"
"Pouch\n"
"Pouches\n"
"Use to collect berries\n"
"Puff Mushroom\n"
"Puff Mushrooms\n"
"[E16213]Calories: 10[-]\n"
"Quiver\n"
"Quivers\n"
"Holds extra arrows\n"
"Rabbit\n"
"Rabbits\n"
"[E16213]Calories: 600[-]\n"
"Use on fire\n"
"Rabbit Fur\n"
"Crafting ingredient\n"
"Rabbit Fur Boots\n"
"Increases stealth\n"
"Rebreather\n"
"Rebreathers\n"
"Swim further underwater\n"
"Repair Tool\n"
"Repairs structures\n"
"Rock\n"
"Rocks\n"
"Rock Bag\n"
"Rock Bags\n"
"Holds extra rocks\n"
"Rope\n"
"Ropes\n"
"Crafting ingredient\n"
"Rusty Axe\n"
"Rusty Axes\n"
"Skull\n"
"Skulls\n"
"Crafting ingredient\n"
"Slingshot\n"
"Slingshots\n"
"Small Meat\n"
"[E16213]Calories: 300[-]\n"
"Use on fire\n"
"Snack\n"
"Snacks\n"
"[E16213]Calories: 400[-]\n"
"Restores [02a1ff]Energy[-] \n"
"Snow Shoes\n"
"Walk faster in snow\n"
"Snowberries\n"
"[E16213]Calories: 1[-]\n"
"Soda\n"
"Sodas\n"
"[E16213]Calories: 400[-] \n"
"Restores [02a1ff]Energy[-] \n"
"Stealth Armor\n"
"Increases stealth\n"
"Stick\n"
"Sticks\n"
"Stick Bag\n"
"Stick Bags\n"
"Holds extra sticks\n"
"Survival Guide\n"
"Survival Guides\n"
"Book on survival\n"
"Tape labeled 'armsy breakout'\n"
"View on camcorder\n"
"Tape labeled 'Lunch with Megan'\n"
"View on camcorder\n"
"Tape labeled 'Megans arrival'\n"
"View on camcorder\n"
"Tape labeled 'Opening the artifact'\n"
"View on camcorder\n"
"Tape labeled 'Second Artifact Test'\n"
"View on camcorder\n"
"Tape labeled 'Side effects'\n"
"View on camcorder\n"
"Tennis Racket\n"
"Tennis Rackets\n"
"Small Rock\n"
"Small Rocks\n"
"Slingshot ammo\n"
"Small Rock Bag\n"
"Small Rock Bag\n"
"Holds extra small rocks\n"
"Timmy Drawings\n"
"Use as decorations\n"
"Timmy's Toy\n"
"Tooth\n"
"Teeth\n"
"Crafting ingredient\n"
"Tree Sap\n"
"Crafting ingredient\n"
"Turtle Shell\n"
"Turtle Shells\n"
"Use as a sled\n"
"TwinBerries\n"
"[E16213]Calories: 1[-]\n"
"Upgraded Rock\n"
"Upgraded Rocks\n"
"Upgraded Spear\n"
"Upgraded Spears\n"
"Use to catch fish\n"
"Upgraded Stick\n"
"Upgraded Sticks\n"
"Walkie Talkie\n"
"Walkie Talkies\n"
"Communicate With friends\n"
"Waterskin\n"
"Waterskins\n"
"%\n"
"Holds water\n"
"Weak Spear\n"
"Weak Spears\n"
"Use to catch fish\n"
"Wristwatch\n"
"Wristwatches\n"
"Crafting ingredient\n"
"Spear Bag\n"
"Holds extra spears\n"
"Hairspray\n"
"Use with lighter\n"
"Boar Skin\n"
"Crafting ingredient\n"
"Raccoon Skin\n"
"Crafting ingredient\n"
"Artifact\n"
"???\n"
"Warmsuit\n"
"Protects from cold\n"
"Creepy Armor\n"
"Increases [ffce00]Armor[-]\n"
"Timmy photo\n"
"CrossBow\n"
"CrossBow Bolt\n"
"CrossBow Bolts\n"
"Raw {0}\n"
"Dried {0}\n"
"Fresh\n"
"Edible\n"
"Spoilt\n"
" (Equiped)\n"
"clean water\n"
"polluted water\n"
"Empty\n"
"drink\n"
"Eat\n"
"Use\n"
"Store\n"
"Found passenger, seat \n"
" collected\n"
"You have been kicked\n"
"You have been banned by Host\n"
"You have been banned by Host\n"
"You have been kicked\n"
"{0} DAYS {1} HOURS {2} MINUTES {3} SECONDS\n"
"NEW PATCH RELEASING SOON \n"
": DAY \n"
"PLAYERS: {0} / {1}\n"
"play\n"
"read\n"
"take\n"
"charge\n"
"wear\n"
"new item added to todo list\n"
"to do list updated\n"
"+Speed {0}\n"
"+Damage -Speed {0}\n"
"+Damage {0}\n"
"Sticky {0}\n"
"Burning {0}\n"
"Orange {0}\n"
"Blue {0}\n"
"Recharged {0}\n"
"Extra burning {0}\n"
"Incendiary {0}\n"
"Bone {0}\n"
"{0} AMMO\n"
"NEW PLANT DISCOVERED\n"
"NEW ANIMAL DISCOVERED\n"
"Poisoned {0}\n"
"Creating Lobby...\n"
"Talking to Steam...\n"
"Starting Server...\n"
"Joining Lobby {0}...\n"
"Starting Client...\n"
"Talking to PSN...\n"
"Could not create Steam lobby.\n"
"Could not create PSN lobby.\n"
"Could not connect to Steam master server.\n"
"Could not connect to PSN master server.\n"
"Could not start PSN game server.\n"
"Could not start Steam game server.\n"
"Could not join Steam lobby.\n"
"Could not join PSN lobby.\n"
"Lobby Destroyed\n"
"{0} with light\n"
" and \n"
"UNEQUIP\n"
"GOOD\n"
"COLD\n"
"IN PAIN\n"
"THIRSTY\n"
"HUNGRY\n"
"WEAPON\n"
"A Basic fire that keep you warm during cold nights\n"
"Build a Fire. It can be used to keep warm,\\nlight up dark nights or scare off enemies\\nbut be warned at night fires may attract\\nunwanted attention to your base.\n"
"Eating food is the best way to keep your\\nEnergy Levels high. Learn about more\\nvarieties in the Food Section of this book.\n"
"Berries are a dark shiny black colour and\\nform in pairs\n"
"A large longer lasting fire that can be seen from afar\n"
"Store live rabbits in a cage and watch them multiply\n"
"Ideal for drying and preserving meats\n"
"A longer lasting fire that you can also relight if it goes out\n"
"Use this fire type to light your camp at night\n"
"Plant seeds to grow food close to your shelter\n"
"Weight\n"
"Store rainwater close to your shelter\n"
"HINT: COVER YOURSELF IN MUD TO HIDE FROM ENEMIES\n"
"HINT: BEING COLD WILL DRAIN YOUR ENERGY\n"
"HINT: KEEP YOUR ENERGY UP BY EATING REGULARLY\n"
"HINT: YOU CAN REGAIN ENERGY BY RESTING ON BENCH\n"
"HINT: EXPLOSIVES AND MOLOTOVS ARE EFFECTIVE AGAINST MOST ENEMIES\n"
"HINT: TRY UPGRADING YOUR WEAPONS\n"
"HINT: YOU CAN MAKE ARMOR OUT OF LIZARD SKIN\n"
"HINT: LIT EFFIGIES WILL SCARE ENEMIES AWAY FROM YOUR CAMP\n"
"HINT: HIDE IN BUSHES TO ESCAPE FROM ENEMIES\n"
"HINT: BUILD A SHELTER TO SAVE YOUR GAME\n"
"HINT: FIND A POT TO BOIL WATER\n"
"ACTION\n"
"ADJUST BRIGHTNESS\n"
"CONTROLLER SPEAKER\n"
"ALT ACTION\n"
"AUDIO MODE\n"
"BARELY\\nVISIBLE\n"
"CAMERA\n"
"CAMERA, PRESS TO CROUCH\n"
"CLEARLY\\nVISIBLE\n"
"INVENTORY\n"
"ITEM\n"
"JUMP\n"
"LIGHTER\n"
"MAP\n"
"MOVE, PRESS TO SPRINT\n"
"NOT\\nVISIBLE\n"
"PERFORMANCE MODE\n"
"STEREO\\nSURROUND\\nSMALL TV\\nHEADPHONES\\nNIGHT MODE\\nSTREAMER\n"
"ROTATE BUILDING\n"
"SURVIVAL GUIDE\n"
"TAKE/BUILD\n"
"UTILITY\n"
"PREVIOUS CHAPTER\n"
"NEXT CHAPTER\n"
"PREVIOUS PAGE\n"
"NEXT PAGE\n"
"HORIZONTAL\n"
" RIGHT\n"
" LEFT\n"
"VERTICAL\n"
" FORWARD\n"
" BACKWARD\n"
"LOOK X\n"
" LOOK RIGHT\n"
" LOOK LEFT\n"
"LOOK Y\n"
" LOOK UP\n"
" LOOK DOWN\n"
"RUN\n"
"CROUCH\n"
"PRIMARY FIRE\n"
"REST\n"
"CRAFT\n"
"ITEM SLOT 1\n"
"ITEM SLOT 2\n"
"ITEM SLOT 3\n"
"ITEM SLOT 4\n"
"WALKY TALKY\n"
"BATCH\n"
"PLAYER LIST\n"
"RED BEANIE\n"
"BLUE BEANIE\n"
"GREEN BEANIE\n"
"BLUE JEANS\n"
"BLACK JEANS\n"
"CAMO JEANS\n"
"KHAKI JEANS\n"
"BEIGE CARGO PANTS\n"
"BLACKSUIT\n"
"DARKGREY HOODIE\n"
"GREY HOODIE\n"
"GREEN HOODIE\n"
"JACKET\n"
"LEATHER JACKET\n"
"CLOSED SHIRT\n"
"OPEN SHIRT\n"
"DARKBLUE VEST\n"
"DARKGREEN VEST\n"
"COLORFUL VEST\n"
"WHITE TSHIRT\n"
"CAMO TSHIRT\n"
"WOLF TSHIRT\n"
"GREY TSHIRT\n"
"BLUE BUTTON UP SHIRT\n"
"WHITE BUTTON UP SHIRT \n"
"GREY LONG SHIRT\n"
"BLACK VNECK SHIRT\n"
"STEWARDESS DRESS\n"
"BATHROBE\n"
"BATHROBE PANTS\n"
"TENNIS OUTFIT\n"
"PILOT UNIFORM\n"
"OLD SUIT\n"
"ALPINE TREEHOUSE\n"
"ANIMALS 1\n"
"ANIMALS 2\n"
"ANIMALS 3\n"
"Arm Effigy\n"
"ARMOR RACK\n"
"ARROW BASKET\n"
"BASIC\n"
"SIMPLE STAIRS\n"
"BASIC STRUCTURES\n"
"BASIC WALL\n"
"WALL WITH DOOR\n"
"WALL WITH WINDOW\n"
"BASIC FIRE\n"
"BASICS OF SURVIVAL TUTORIAL\n"
"BASICS OF SURVIVAL\n"
"2 STICKS\n"
"6 ROCKS\n"
"7 LOGS\n"
"7 STICKS\n"
"STEP ONE\n"
"Build a shelter. \\nA shelter can be used to sleep \\nand to save your game.\\n\n"
"Consider Building a shelter before heading out \\ninto the unknown woods.\n"
"7 LEAVES\n"
"STEP TWO\n"
"Build a fire. \\nIt can be used to keep warm, light up \\ndark nights or scare off enemies but \\nbe warned at night, fires may \\nattract unwanted attention.\n"
"Fire is extremely valuable in a survival situation. \\nYou can also use fire or a torch to light your way\\n in dark caves.\n"
"THE BERRIES ARE AN\\r\\n<color=#9370DBFF>INDIGO COLOUR</color> AND\\r\\nHAVE A LITTLE CROWN\\r\\nON THE TIP.\n"
"EDIBLE\n"
"FORAGING\n"
"POISONOUS\n"
"STEP THREE\n"
"BERRIES ARE A DARK\\r\\nSHINY <color=#000000FF>BLACK COLOUR</color>\\r\\nAND FORM IN PAIRS.\n"
"Here is an example of two similar looking berries. \\nOne is edible, the other poisonous.\n"
"Be careful, use reference \\nand make sure you know what you\\u2019re eating \\nbefore you eat it.\n"
"BIRDHOUSE\n"
"BOATS\n"
"BONE CHAIR\n"
"BONE CHANDELIER\n"
"BONE FRAME\n"
"BONE BASKET\n"
"BONE FENCE\n"
"BON FIRE\n"
"CAR\n"
"CATAPULT\n"
"CEILING SKULL LAMP\n"
"CHAIR\n"
"CHURCH\n"
"CLIMBING ROPE\n"
"LOG TRACK\n"
"COFFIN\n"
"COUCH\n"
"TO CRAFT AN ITEM, YOU NEED TO\\nCOLLECT THE REQUIRED AMOUNT\\nOF RESOURCES\n"
"CRAFTING\n"
"CRAFTING GUIDE\n"
"CRAFTING GUIDE\n"
"CRANE\n"
"CROSS\n"
"CUSTOM BUILDING\n"
"CUSTOM 1\n"
"CUSTOM 2\n"
"CUSTOM 3\n"
"RABBITSKIN\n"
"DECORATIVE SKULL\n"
"HEAD TROPHY\n"
"WALL PLANTER\n"
"WEAPON DISPLAY\n"
"DEERSKIN\n"
"DECORATIONS\n"
"DECORATIONS 1\n"
"DECORATIONS 2\n"
"DECORATIONS 3\n"
"DEFENSIVE SPIKES\n"
"DEFENSIVE WALL SPIKES\n"
"DEFENSIVE WALLS\n"
"DOCK\n"
"DOG\n"
"DRYING RACK\n"
"Effigies\n"
"PROPS\n"
"Custom Effigy\n"
"Large Effigy\n"
"RAIN EFFIGY\n"
"Small Effigy\n"
"ELEVATED\n"
"EXPLOSIVES HOLDER\n"
"FAMILY\n"
"FIRE\n"
"FIRE PIT\n"
"FIREPLACE\n"
"STANDING FIRE\n"
"CUSTOM FLOOR\n"
"FOOD\n"
"FOOD AND WATER\n"
"CUSTOM FOUNDATION\n"
"FURNITURE\n"
"FURNITURE 1\n"
"FURNITURE 2\n"
"GARDEN\n"
"GAZEBO\n"
"GLIDER\n"
"HOLE CUTTER\n"
"HOUSE BOAT\n"
"HUNTING SHELTER\n"
"THIS BOOK CONTAINS INSTRUCTIONS TO\\r\\nBUILD THE TOOLS AND ITEMS YOU NEED TO\\r\\nSURVIVE ALONE IN THE WILDERNESS\n"
"SURVIVAL\n"
"OVAL-LEAVES BLUEBERRIES\n"
"BLACK TWINBERRY\n"
"ITEMS NEEDED:\n"
"LARGE CABINET\n"
"LARGE RAFT\n"
"LEAF PILE TRAP\n"
"LOG CABIN\n"
"SMALL CABIN\n"
"LOG HOLDER\n"
"LOG SLED\n"
"MAIN INDEX\n"
"NATURE GUIDE\n"
"NATURE GUIDE\n"
"ALOE\n"
"BIG BROWN BAT\n"
"BLACK TWINBERRY\n"
"BLACKBERRIES\n"
"BLUEBIRD\n"
"BLUECHEEK BUTTERFLYFISH\n"
"BOAR\n"
"CANADA GOOSE\n"
"CARDINAL\n"
"CARP\n"
"CAVE FISH\n"
"CHANTERELLE MUSHROOM\n"
"CHICORY\n"
"COD\n"
"CONEFLOWER\n"
"CROCODILE\n"
"CROW\n"
"DANDELION\n"
"DEER\n"
"DEER MUSHROOM\n"
"EUROPEAN RABBIT\n"
"FIREWEED\n"
"FLY AGARIC\n"
"GLAUCOUS WINGED GULL\n"
"GOANNA LIZARD\n"
"GREAT WHITE SHARK\n"
"HORSETAIL\n"
"JACK O LANTERN MUSHROOM\n"
"LIBERTY CAP MUSHROOM\n"
"LOGGERHEAD\\nSEA TURTLE\n"
"MARIGOLD\n"
"OVAL-LEAVES BLUEBERRIES\n"
"PALETTE SURGEONFISH\n"
"POISON PUFF\\nMUSHROOM\n"
"RACCOON\n"
"ROBIN\n"
"ROCK BEAUTY\n"
"SNOWBERRY\n"
"SNOWSHOE RABBIT\n"
"SQUIRREL\n"
"THISTLE\n"
"TORTOISE\n"
"YELLOWTAIL TANG\n"
"NOTES\n"
"PLANT LIFE 1\n"
"PLANT LIFE 2\n"
"PLATFORM\n"
"RABBIT CAGE\n"
"RABBIT TRAP\n"
"SMALL RAFT\n"
"ROCK PATH\n"
"ROCK HOLDER\n"
"ROCK WALL\n"
"CUSTOM ROOF\n"
"SHELTERS\n"
"SIDE TABLE\n"
"SIGNALS\n"
"BUILD A SIGNAL. NEVER GIVE UP HOPE.\n"
"TIMMY SITTING\n"
"WIFE SITTING\n"
"SKIN RACK\n"
"SKULL LAMP\n"
"SMALL BED\n"
"SMALL CABINET\n"
"SOS SIGN\n"
"CUSTOM STAIRS\n"
"TIMMY\n"
"ARMOR\n"
"COLD ARMOR\n"
"ATHLETICISM\n"
"CONDITIONS:\n"
"CURRENTLY FEELING\n"
"DAYS SURVIVED\n"
"ENERGY\n"
"FULLNESS\n"
"HEALTH\n"
"HYDRATION\n"
"Infected\\nfind aloe to heal\n"
"SANITY\n"
"Sick\\nfind aloe to cure or get some rest\n"
"STAMINA\n"
"STEALTH\n"
"STRENGTH\n"
"WEIGHT\n"
"STATS\n"
"STATS\n"
"STEP ONE\n"
"STEP THREE\n"
"STEP TWO\n"
"STICK FRAME\n"
"STICK FENCE\n"
"STICK HOLDER\n"
"STICK MARKER\n"
"STORAGE\n"
"STORAGE1\n"
"STORAGE2\n"
"STORAGE3\n"
"TABLE\n"
"WOOD TARGET\n"
"explore chasm cave\n"
"explore dead cave \n"
"explore hanging cave\n"
"explore lawyers cave\n"
"explore ledge cave\n"
"explore sinkhole cave\n"
"explore submerged cave\n"
"explore waterfall cave\n"
"explore wet cave\n"
"find a new sacrifice\n"
"find a way into the sinkhole\\r\n"
"find and cook food\\r\n"
"find live sacrifice\n"
"find the missing plane passengers\n"
"find the red man\n"
"Find timmy\n"
"Find way to climb rock walls\n"
"Find way to stay underwater longer\n"
"keep exploring hanging cave\n"
"set up camp\\r\n"
"set up defenses\\r\n"
"TEMPORARY SHELTER\n"
"TODO\n"
"TO DO LIST\n"
"TOWER\n"
"DEADFALL TRAP\n"
"NOOSE TRAP\n"
"TRAPS\n"
"TRAPS AND DEFENSE\n"
"SMALL TRAPS\n"
"ADVANCED TRAPS\n"
"DEFENSE\n"
"HAPPY BIRTHDAY TRAP\n"
"ROPE SWING TRAP\n"
"TREE BRIDGE\n"
"TREE HOUSE\n"
"TREE PLATFORM\n"
"TREE SAP COLLECTOR\n"
"TREE ZIPLINE\n"
"TV\n"
"UTILITY\n"
"UTILITY 1\n"
"UTILITY 2\n"
"CUSTOM WALLS\n"
"WATER COLLECTOR\n"
"WEAPON RACK\n"
"EXPLOSIVES WIRE TRAP\n"
"MOLOTOV WIRE TRAP\n"
"WOOD BENCH\n"
"FREE STANDING ZIP-LINE\n"
"Burnt\n"
"Daily calories:\n"
"Eaten\n"
"MOLOTOV\n"
"WIFE\n"
"2. PRESS TO ADD ITEMS TO CRAFTING AREA\n"
"3. PRESS \\n\\n\\nTO CRAFT ITEM\n"
"1. PRESS\\n\\n\\nTO OPEN YOUR INVENTORY\n"
"THIS IS YOUR CRAFTING MAT\n"
"YOU CAN VIEW\\nRECIPES BY HOVERING \\nOVER THE COG AFTER \\nADDING AN ITEM\n"
"ALL\n"
"Search by name...\n"
"FRIENDS\n"
"SEARCH\n"
"EDIT FIELD\"\n")
subst = "${prefix}<color=#${code}>${suffix}</color>"
result = regex.sub(subst, test_str)
if result:
print(result)