#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[ \t])((?:\d{5}(?=[^\d-]|$))|(?:\d{5}-\d{4}(?=[^\d-]|$)))"
Local $sString = "Should match:" & @CRLF & _
" 92120" & @CRLF & _
" 11345-1234" & @CRLF & _
"" & @CRLF & _
"Should not match:" & @CRLF & _
"" & @CRLF & _
"92120" & @CRLF & _
" 1234567 " & @CRLF & _
" 11345-1234567" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")