$re = '/<.[^>]*>(.*?)</';
$str = '<p>content1<a>content2 <span>content3</span></a> content4</p>
<a href="link">content1 <span>content2</span> content3</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);