const regex = /#[\s\S]*?(Людовик)[\s\S]*?(Людовик)[\s\S]*?(Людовик)[\s\S]*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#[\\s\\S]*?(Людовик)[\\s\\S]*?(Людовик)[\\s\\S]*?(Людовик)[\\s\\S]*', '')
const str = `
ЛюдовикXV, ЛюдовикXVI, ЛюдовикXVIII, ЛюдовикLXVII, ЛюдовикXXL
ЛюдовикXV, ЛюдовикXVI, ЛюдовикXVIII, ЛюдовикLXVII, ЛюдовикXXL
# ЛюдовикXV, ЛюдовикXVI, ЛюдовикXVIII, ЛюдовикLXVII, ЛюдовикXXL
ЛюдовикXV, ЛюдовикXVI, ЛюдовикXVIII, ЛюдовикLXVII, ЛюдовикXXL
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}