// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)\([^\)]*,[^\)]*\)").unwrap();
let string = "The emergence of two distinct leadership roles, the task leader and the socio-emotional leader, has been documented in the leadership literature since the 1950s (Bales, 1958). The separation of these roles has been seen as pragmatic in applications and is accepted as a finding in behavioral research. However, in practical applications, it leaves an organization with a challenge that can detract from leadership development, succession planning, and organizational flexibility. In this article, we will show that the division between these two types of leadership roles lies far deeper than has traditionally been thought. Recent research in neuroscience suggests that the division between task-oriented and socio-emotional leadership roles derives from a fundamental feature of our neurobiology: an antagonistic relationship between two large-scale cortical networks that is present in every individual.
Neural activity in the task-positive network (TPN) tends to inhibit activity in the default mode network (DMN; Raichle et al., 2001; Fransson, 2005; Raichle and Snyder, 2007; Buckner et al., 2008), and vice versa (Uddin et al., 2009; Jack et al., 2012). The TPN is activated during a broad range of non-social tasks (Fox et al., 2005; Buckner et al., 2008; Uddin et al., 2009; Andrews-Hanna, 2012), and is thought to be important for problem solving, focusing of attention, making decisions, and control of action – in other words for getting things done. However, activation of the TPN also has a deleterious effect on other cognitive functions that are essential to leadership: it suppresses activity in the DMN.
The DMN plays a central role in emotional self-awareness (Ochsner et al., 2005; Schilbach et al., 2008), social cognition (Schilbach et al., 2008; Jack et al., 2012; Mars et al., 2012), and ethical decision making (Koenigs et al., 2007; Bzdok et al., 2012; Jack et al., in press). It is also strongly linked to creativity and insightful problem solving (Subramaniam et al., 2009; Takeuchi et al., 2011). The antagonistic relationship between the TPN and DMN creates a fundamental neural constraint on cognition that is highly relevant to the different roles and capabilities that effective leaders must astutely juggle and deploy. An important consequence of this constraint is that an over-emphasis on task-oriented leadership can prove deleterious to an organization: in particular when openness to new ideas, people, emotions, and ethical concerns are important to success. On the other hand, the over emphasis on relationship oriented leadership may prove deleterious to focus and the execution of clearly defined goals.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}