$re = '/(?<!\s)(?=\s)/';
$str = 'Don\'t you love it when you install all software and all programs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);