package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(?([^,\)]+)[\),]?`)
var str = `(111111111111,'222222222',"3333333")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}