$re = '/(.)(?=(.*?\1){3,})/';
$str = '0w612365wwadw-..';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);