$re = '/^[a-zA-Z]+(?:\'[a-zA-Z]+)*$/m';
$str = 'a\'a\'a\'a
a\'
\'a
a\'a\'
b\'b
a\'a
aa\'a
a\'aaa
bb\'
\'bb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);