re = /(\d[.#]*)/m
str = 'Lorem ipsum dolor sit amet, consetetur sadipscing elitr, 1.6.2# sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end