$re = '/\[Power\] GameState\.DebugPrintPower\(\)\s*-\s*CREATE_GAME/';
$str = '[Power] GameState.DebugPrintPower() - CREATE_GAME';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);