re = /[.!?]<\/h[1-6]>(*SKIP)(*FAIL)|<\/h[1-6]>/
str = '<p>Today, not only we have so many breeds that are trained this and that.</p>
<h4><strong>We must add a dot after the closing strong</strong></h4>
<p>Hunting with your dog is a blah blah with each other.</p>
<h2>No need to change this one!</h2>
<p>Hunting with your dog is a blah blah with each other.</p>'
subst = '.$0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result