package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(?m)\bc\w.`)
    var str = `cheese
city
cheek
could
cast
crush`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}