re = /\bfunction(?:\s+[a-zA-Z0-9._]*)?\(((?:(?=([a-zA-Z_][a-zA-Z0-9_]*))\2|\.\.\.|,\s*)*)\)/
str = 'function f(aaaaaaa, bbbbbbbb, cccccccc, ddddddd eeeeee)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end