import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<)([a-zA-Z0-9:.]+)(?:(?: ((?<= )[^ ]+?(?==| |>)))(?:=[^ >]+)(?: |>))";
final String string = "<div attr=\"Something\" data-attr=\"test\" data-foo> adsfasd asdfasd fasdf\n"
+ "<div attr=\"Something\" data-attr=\"test\">\n"
+ "<div attr=\"Something\">\n"
+ "<a href=\"\"/>\n"
+ "<div attr=\"Something\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}