re = /^(-) (.{1,})\n(.+(^- ))/m
str = '- hallo welt
-- hello world
Saluton Mondo
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end