#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|[^\d,])(\d+)(?![,\d])"
Local $sString = " The First 1,000,000 Primes (from primes.utm.edu)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" 2 3 5 7 11 13 17 19 " & @CRLF & _
"" & @CRLF & _
" 23 29 31 37 41 43 47 53 " & @CRLF & _
"" & @CRLF & _
" 59 61 67 71 73 79 83 89 " & @CRLF & _
"" & @CRLF & _
" 97 101 103 107 109 113 127 131 " & @CRLF & _
"" & @CRLF & _
" 137 139 149 151 157 163 167 173 " & @CRLF & _
"" & @CRLF & _
" 179 181 191 193 197 199 211 223 " & @CRLF & _
"" & @CRLF & _
" 227 229 233 239 241 251 257 263 " & @CRLF & _
"" & @CRLF & _
" 269 271 277 281 283 293 307 311 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")