package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^100(\.0{1,2})?$)|(^([1-9]([0-9])?|0)(\.[0-9]{1,2})?$)`)
var str = `1234232342`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}