re = /Job Title: ([A-Z]\w* [A-Z]\w*(?: [A-Z]\w*)?)/i
str = 'Job Title: Some Word Here
Job Title: Some Word
Job Title: Professor of Archeology
Job Title: Dean of Students
Job Title: Queen of England'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end