#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(.+?)([\s,.!?;:)([\]]+)"
Local $sString = "Cum a Romanis copiis vincĭtur măr, Gallia terra fera est. " & @CRLF & _
"Regionis incŏlae terram non colunt, autem sagittis feras necant et postea eas vorant. " & @CRLF & _
"Etiam a_femĭnis vita agrestis agĭtur, " & @CRLF & _
"miseras vestes induunt et cum familiā in parvis casis vivunt. " & @CRLF & _
"Vita secūra nimiaeque divitiae a Gallis contemnuntur. " & @CRLF & _
"Gallorum civitates acrĭter pugnant et ab inimicis copiis timentur. " & @CRLF & _
"Galli densis silvis defenduntur, tamen Roma feram Galliam capit. "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")