re = /^(?=[^+]*(?:\+[^+]+){0,2}[^+]*$)(?=[^()]*(?:\([^()]*\))?[^()]*$)[\d\/. ()\-+]+$/m
str = '12(3)+4+4
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end