use strict;
my $str = '29047531,000000029047531,70098877,000000000206616,TEST_MID_a8c59c12-5ffa-43dc-81f8-0ea4e9435a4d,000000000206616,TEST_MID_a8c59c12-5ffa-43dc-81f8-0ea4e9435a4d,TEST_MID_0ae1a070-7868-4543-811f-695f298cc9af,000000000206616,TEST_MID_a8c59c12-5ffa-43dc-81f8-0ea4e9435a4d,TEST_MID_0ae1a070-7868-4543-811f-695f298cc9af,TEST_MID_e189672a-9660-42a8-805b-b4e1f7fb431b,000000000206616,TEST_MID_a8c59c12-5ffa-43dc-81f8-0ea4e9435a4d,TEST_MID_0ae1a070-7868-4543-811f-695f298cc9af,TEST_MID_e189672a-9660-42a8-805b-b4e1f7fb431b,TEST_MID_75dc1b8b-7531';
my $regex = qr/0*([0-9]+)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";