#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(\w+\s+)(\w+\?*\s+)(\w+)\s+(\{.+\})"
Local $sString = "public Guid DellUploadItemID { get; set; }" & @CRLF & _
"public Guid UploadID { get; set; }" & @CRLF & _
"public string DellPurchaseID { get; set; }" & @CRLF & _
"public string PoNum { get; set; }" & @CRLF & _
"public string OrderNum { get; set; }" & @CRLF & _
"public string OrderType { get; set; }" & @CRLF & _
"public string InvoiceNum { get; set; }" & @CRLF & _
"public string PaymentDescription { get; set; }" & @CRLF & _
"public DateTime? OrderDate { get; set; }" & @CRLF & _
"public DateTime? ShippedDate { get; set; }" & @CRLF & _
"public DateTime? InvoiceDate { get; set; }" & @CRLF & _
"public decimal ReportLineTotal { get; set; }" & @CRLF & _
"public string ServiceTag { get; set; }" & @CRLF & _
"public string Category { get; set; }" & @CRLF & _
"public string SubCategory { get; set; }" & @CRLF & _
"public string Item { get; set; }" & @CRLF & _
"public string ItemLongName { get; set; }" & @CRLF & _
"public DateTime? WarrantyEndDate { get; set; }" & @CRLF & _
"public string ShipFirstName { get; set; }" & @CRLF & _
"public string ShipLastName { get; set; }" & @CRLF & _
"public string ShipToCompany { get; set; }" & @CRLF & _
"public string ShipAddress1 { get; set; }" & @CRLF & _
"public string ShipAddress2 { get; set; }" & @CRLF & _
"public string ShipCity { get; set; }" & @CRLF & _
"public string ShipState { get; set; }" & @CRLF & _
"public string ShipZip { get; set; }" & @CRLF & _
"public string ShipMethod { get; set; }" & @CRLF & _
"public string CarrierName { get; set; }" & @CRLF & _
"public string WaybillNumber { get; set; }" & @CRLF & _
"public string ExpressServiceCode { get; set; }" & @CRLF & _
"public string MACAddress { get; set; }" & @CRLF & _
"public string MACAddress2 { get; set; }"
Local $sSubst = "\3 = d.\3,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)