import re
regex = re.compile(r"(?<=has been denied).*(401 to \d{1,3}.\d{1,3}.\d{1,3}.\d{1,3})", flags=re.DOTALL)
test_str = ("2016-02-14 15:55:39.1094 Info HttpServer: HTTP Response 200 to 192.168.0.3. Time: 3ms. https://192.168.0.10:8920/emby/users/public\n"
"2016-02-14 15:55:43.8597 Info HttpServer: HTTP POST https://192.168.0.10:8920/emby/Users/authenticatebyname. UserAgent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0\n"
"2016-02-14 15:55:43.8718 Info UserManager: Authentication request for <username> has been denied.\n"
"2016-02-14 15:55:43.8820 Error DtoUtils: ServiceBase<TRequest>::Service Exception\n"
" *** Error Report ***\n"
" Version: 3.0.5821.0\n"
" Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -restartpath /usr/lib/emby-server/restart.sh\n"
" Operating system: Unix 3.19.0.25\n"
" Processor count: 8\n"
" 64-Bit OS: True\n"
" 64-Bit Process: True\n"
" Program data path: /var/lib/emby-server\n"
" Mono: 4.2.1 (Stable 4.2.1.102/6dd2d0d Thu Dec 3 04:04:55 UTC 2015)\n"
" Application Path: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe\n"
" Invalid user or password entered.\n"
" MediaBrowser.Controller.Net.SecurityException\n"
" at MediaBrowser.Server.Implementations.Session.SessionManager+<AuthenticateNewSession>c__asyncC.MoveNext () <0x41c76b00 + 0x0080b> in <filename unknown>:0\n"
" --- End of stack trace from previous location where exception was thrown ---\n"
" at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x7fa7314f36d0 + 0x00029> in <filename unknown>:0\n"
" at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x7fa7314f16b0 + 0x000a7> in <filename unknown>:0\n"
" at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x7fa7314f1630 + 0x0006b> in <filename unknown>:0\n"
" at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x7fa7314f15e0 + 0x0003a> in <filename unknown>:0\n"
" at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x7fa7314f1d10 + 0x00017> in <filename unknown>:0\n"
" at MediaBrowser.Api.UserService+<Post>c__async1.MoveNext () <0x41c75ea0 + 0x00680> in <filename unknown>:0\n\n"
"2016-02-14 15:55:43.8849 Error HttpServer: Error processing request for /emby/Users/authenticatebyname\n"
" *** Error Report ***\n"
" Version: 3.0.5821.0\n"
" Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -restartpath /usr/lib/emby-server/restart.sh\n"
" Operating system: Unix 3.19.0.25\n"
" Processor count: 8\n"
" 64-Bit OS: True\n"
" 64-Bit Process: True\n"
" Program data path: /var/lib/emby-server\n"
" Mono: 4.2.1 (Stable 4.2.1.102/6dd2d0d Thu Dec 3 04:04:55 UTC 2015)\n"
" Application Path: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe\n"
" Invalid user or password entered.\n"
" ServiceStack.HttpError\n"
" No Stack Trace Available\n\n"
"2016-02-14 15:55:43.8913 Info HttpServer: HTTP Response 401 to 192.168.0.3. Time: 32ms. https://192.168.0.10:8920/emby/Users/authenticatebyname\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")