import re
regex = re.compile(r"(?=^(?:(?!key[12]).)*$)^.*?(?=\s\d+)", flags=re.MULTILINE)
test_str = ("this is a number 123456789 and there aren't any keys here. we might have a lot of words here as well but no key words\n"
"this is a number 123456789 but we have their key1 here. key2 might be in the second or the third sentence. hence we can't remove everything after the given number")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")