import re
regex = re.compile(r"(?![_a-zA-Z][_a-zA-Z0-9]*)")
test_str = ("asdsa\n"
"****\n"
"sadasd\n"
"555\n"
"654654\n"
"sasdasdad\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")