re = /^\$?[+-]?[0-9]{1,3}(?:[0-9]*(?:[.,][0-9]{2})?|(?:,[0-9]{3})*(?:\.[0-9]{2})?|(?:\.[0-9]{2}))$/
str = '$9.00'
# Print the match result
str.match(re) do |match|
puts match.to_s
end